Start a new topic

How can i connect admin UI?

hello.


I did install CrushFTP7_PC in linux server.

Directory : /var/opt/CrushFTP7_PC/


I command 

/var/opt/CrushFTP7_PC:> ./crushftp_init.sh start


and nohup.out is empty.

/var/opt/CrushFTP7_PC:> cat nohup.out 

/var/opt/CrushFTP7_PC:> 


CrushFTP.log 

   

RUN_SERVER|03/23/2015 05:55:49 PM|********CrushFTP Run******** Version 7.3.0_9  Java:1.6.0_37 from:/usr/java/jdk1.6.0_37/jre 64 bit  OS:Linux
SERVER|03/23/2015 05:55:49 PM|Port 8080 is already in use by another process.
START|03/23/2015 05:55:49 PM|---Server Started--- LAN IP=210.102.77.29 WAN IP=210.102.77.29 PORT=9090
START|03/23/2015 05:55:49 PM|---Server Started--- LAN IP=210.102.77.29 WAN IP=210.102.77.29 PORT=2222
ACCEPT|03/23/2015 05:55:49 PM|Java version is 1.6.0_37
ACCEPT|03/23/2015 05:55:49 PM|OS is Linux

.........

ACCEPT|03/23/2015 05:55:50 PM|Initializing Secure Random Number Generator
ACCEPT|03/23/2015 05:55:50 PM|Configuration complete.
ACCEPT|03/23/2015 05:55:50 PM|Binding server to /127.0.0.1:36792
SERVER|03/23/2015 05:55:59 PM|Server Memory Stats: Max=341.37 MB, Free=321.36 MB

   

But I can NOT connect admin UI.

http://serverIp:9090/WebInterface/login.html


Could you help  me ? 


thanks


Hello kssung

*Port 8080 is already in use by another process* probably httpd is listening on port #8080 (web proxy). As for port #9090 it might very well be blocked by iptables.
Check what is listening on which port : netstat -tulpn
Check iptables policies: iptables -L
Open port on iptables: iptables -A INPUT -p tcp --dport <your_port_no> -j ACCEPT

Now if you are using a linux machine with graphical desktop and you want to access WebInterface locally, you might want to
enable all for the loopback interface 'lo' : iptables -A INPUT -i lo -j ACCEPT

That should cover it.










thank for your answer.


 I did check  and command iptables.


so now..


netstat -tulpn 

Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name   
tcp        0      0 :::9090                     :::*                        LISTEN      7727/java  
tcp        0      0 :::2222                     :::*                        LISTEN      7727/java    

 


 iptables -L

target     prot opt source               destination       
ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:websm 

 


but  I can not access admin UI yet.



are you running Centos7 by any chance ?

 

if so, check if firewalld is running

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/Security_Guide/sec-Using_Firewalls.html

 

thank you ,  It's my fault .. because firewall 

Login to post a comment