Start a new topic

How to remove the ".." folder at the top of folder list

foolhardy @ Tue Feb 03 08:35:49 EET 2015
I'm running an SFTP site with CrushFTP7. How can I go about telling CrushFTP not to list the ".." folder ? It shows up in both Filezilla client and CoreFTP. It does not show up for other SFTP sites that I use.

[img]http://i.imgur.com/FhDBEer.png[/img]

spinkb @ Tue Feb 03 10:53:44 EET 2015
Update now to the latest build.

Then edit your reps.xml file and set the flag "send_dot_dot_list_sftp" to be false.

Thanks,
Ben
foolhardy @ Tue Feb 03 10:57:51 EET 2015
[quote=spinkb]Update now to the latest build.

Then edit your reps.xml file and set the flag "send_dot_dot_list_sftp" to be false.

Thanks,
Ben[/quote]

Ben,
Thanks a lot for your input. Where can I find reps.xml? I'm having trouble locating it.
spinkb @ Tue Feb 03 11:43:44 EET 2015
Sorry, typo.

prefs.xml

in the CrushFTP folder.
foolhardy @ Tue Feb 03 13:27:51 EET 2015
I find no send_dot_dot_list_sftp in prefs.xml. I have updated / yum update (CentOS7).

I set false, from default true. I restarted the crushftp service and then I restarted the entire machine but I still get the dot dot folder in listings.

Any other suggestions?

Thank you for your input.
spinkb @ Tue Feb 03 13:35:42 EET 2015
Did you update CrushFTP? Until you do, you won't have that option.
foolhardy @ Tue Feb 03 13:44:35 EET 2015
Hmmmm, in that case it sounds like I did not update it. I'm trying to figure out how to update specifically CrushFTP in CentOS7. Thanks for your help, spinkb.

EDIT: I found the update in the web admin. Updated and then found send_dot_dot_list_sftp in prefs.xml.

Thanks for all your help!
spinkb @ Tue Feb 03 13:51:18 EET 2015
Login to admin, click about tab, click update.

Thanks,
Ben
foolhardy @ Tue Feb 03 13:52:25 EET 2015
spinkb, you nailed it! Thanks for all your help!
Login to post a comment