Start a new topic

CrushFTP-Webinterface linking to an Apache

bj @ Mon Jan 19 06:12:30 EET 2015
Hi Ben,

i use currently the CrushFTP version 7.2.0_87.

i installed all fine.
in the crushftp "preferences" under "ip/servers" i configured for example:

[b][i]ftp://192.168.51.165:21
sftp://192.168.51.165:2222
https://192.168.51.165:443[/i][/b]

all protocols are working.
crushftp ist listening through an static-ip from my provider for external usage.
this external static-ip then routes the request to my crushftp server with 192.168.51.165.
so crushftp ist listening on https://exampledomain.de for example.

now i customized the default crushftp webinterface and added there an link with:
[b][i]https://exampledomain.de/myregistration/[/i][/b]

all i want is now, that the link "https://exampledomain.de/myregistration/" will not lead to CrushFTP but rather to an Apache Webserver which i configured on the same machine.
there is an html-form and an php-file which creates directories ("magic-directory") for auto-user registration/creation.
the apache webserver got an own ip-adress with: 192.168.51.166.
i configured on the apache SSL.

apache conf cutouts:
[b]...
Listen 192.168.51.166:443
...

ServerName exampledomain2.de
ServerAdmin mail@xxx.de

DocumentRoot /home/crushftp/crushftp/WebInterface/myregistration/


Options FollowSymLinks
AllowOverride None



Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all


ErrorLog /var/log/apache2/host-error_log
CustomLog /var/log/apache2/host-access_log combined

SSLEngine On

# Patch for Poodle-Attack
SSLProtocol ALL -SSLv2 -SSLv3

# SSL Cipher Suite:
#SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLCipherSuite EECDH+AES:EDH+AES:-SHA1:EECDH+RC4:EDH+RC4:RC4-SHA:EECDH+AES256:DHE+AES256:AES256-SHA:!aNULL:!eNULL:!EXP:!LOW:!MD5:!RC4
SSLHonorCipherOrder on


# Server Certificate:
SSLCertificateFile /home/xxx/key/xxx.crt

# Server Private Key:
SSLCertificateKeyFile /home/xxx/certificate/xxx.key


...[/b]

i forgot, in the crushftp preferences i configured at the "advanced" tab of "https://192.168.51.151":

[b][i]
IP: 192.168.51.165
Port: 443
Web Access SSL (HTTPS://): activated

Allow Users To Use WebDAV: activated
Redirected to HTTPS://: activated

ReverseProxy Path (CrushFTP is behind a proxy): /
ReverseProxy Server Configuration:
Domain: exampledomain.de/
URL: https://192.168.51.166
Path: /myregistration/[/i]
[/b]

But if i try the link in my customized login webinterface, i alway get an blank page.
the persmissions on the files and directory are for testing purpose 777.

i hope u can help me.

Thanks, bj



1 Comment

spinkb @ Mon Jan 19 13:59:40 EET 2015
No special apache config should be done. Undo that.

In CrushFTP, only do the reverse proxy part, not where crush is behind a reverse proxy. You are going to have CrushFTP act as your reverse proxy.

Domain: *
URL: http://127.0.0.1:8081/ path: /myregistration/

CrushFTP owns port 443, apache uses 8081 for plain HTTP.

Thanks,
Ben
Login to post a comment