Start a new topic

incorrect email template being sent.

jbalcaen @ Fri Jul 04 16:38:03 EEST 2014
I have created an email template with the following text
[code]Hi, this is the robot running FTP Server The FTP account jotest has just been created by yourself jbalcaen or someone logged in as you. The account will be deleted onunless you login to and change the expiry date prior to the account expiring. Regardless of the expiry date of the account, the data itself has a 28 day retention period, at which point the data will be deleted. FTP details are as follows...[/code]

However, when I send the email template using the [i]Send email with user/pass information[/i] button and then I select the correct template I receive the following :
[code]Your password is : xxxxxx

Requested from IP:%user_ip%[/code]
which is not the template that I set.

What I don't understand is that when I remove all of the text in the template and replace with something like %user_account_expire%, I get the correct the content.

Please help me get the correct email template to be sent.

Thank you!

spinkb @ Fri Jul 04 16:46:57 EEST 2014
What exact CrushFTP version is this?

Thanks,
Ben
jbalcaen @ Mon Jul 07 08:18:58 EEST 2014
Version 7.0.2 Build : 183
spinkb @ Mon Jul 07 08:20:28 EEST 2014
I think we have already fixed this. Current build is 7.0.2_252.

Update by clicking update now and see if you still have an issue.

Thanks,
Ben
jbalcaen @ Tue Jul 08 08:48:55 EEST 2014
I am now on Version 7.0.2 Build : 252.

The same issue persists. I pasted the html version of the email template I am trying to send out:

[code]
Hi, this is the robot running aaaa FTP Server - 

The FTP account '{user_name}' has just been created.

The account will be deleted on %user_account_expire% unless you login to <http://crushftp:8080/#/> and change the expiry date prior to the account expiring.

** Regardless of the expiry date of the account, the data itself has a 28 day retention period, at which point the data will be deleted. **

FTP details are as follows:

------------------------------------------------------------------------

Hostname: ftp2.aaaa.com
Port: 21
Username: {user_name}
Password: {user_pass}
Expires on: %user_account_expire%

------------------------------------------------------------------------

If you wish to upload material from the internal network, simply use ftp2 as the hostname.

Thanks,
        aaaa FTP Server Robot

[/code]
vipul @ Wed Jul 09 02:19:56 EEST 2014
Did you follow these steps to setup email template?

Preferences -> Email Template -> Add New -> Enter and save your template

Now, in User Manager when you click on "Send email with user/pass information" you'll be asked to select template from the list, when you select the template you'll be able to see its content in the same window, confirm it shows you correct text for your email.

Please check this and reply here if any problem.
jbalcaen @ Wed Jul 09 09:30:12 EEST 2014
I have followed the exact steps as you have described.

After selecting the template to send I do in fact see the correct text that is supposed to be sent.

But the email that gets sent to my inbox is :

[code]Your password is : 9XXnr8

Requested from IP:%user_ip%[/code]
spinkb @ Wed Jul 09 09:34:05 EEST 2014
Maybe its the web browser being used?

Or the name you gave the email template? What name did you use on the template?

Thanks,
Ben
jbalcaen @ Wed Jul 09 10:06:37 EEST 2014
I changed the name of the email template and email subject to something shorter with no punctuation and it fixed it!

Must've been a hidden character or maybe it didn't like some of the punctuation.

Its fixed now thanks :D
spinkb @ Wed Jul 09 10:10:32 EEST 2014
Do you know what the name was previously so we can try and debug the issue here?
jbalcaen @ Wed Jul 09 11:33:47 EEST 2014
The subject line was

[quote]Welcome to Framestore FTP server[/quote]

and the template name was the same I believe.
Login to post a comment