Start a new topic

Problems Generating Previews

Serte @ Fri Jun 06 19:56:41 EEST 2014
Just installed CrushFTP today - liking what I see so far!

I'm running Version 7.0.2_194 on Win Server 2008 R2.
the ImageMagick convert appears to be running properly. I get the p1 folder and the 3.jpeg AOK.

This is what the log is generating:

06/06/2014 08:38:06 PM|Preview:Converting: M:PhotoIMG_6800.JPG to: M:/Preview/_-_M_-_/Photo/IMG_6800.JPG exists:false modified:1210900820909 vs 1402101486990
06/06/2014 08:38:06 PM|Preview:Creating thumbnail for:M:PhotoIMG_6800.JPG
06/06/2014 08:38:06 PM|Preview:New item check complete:/M:/Photo/
06/06/2014 08:38:06 PM|Preview:New item check completed.
06/06/2014 08:38:07 PM|Preview:CMD /C convert.exe -colorspace RGB -alpha off -strip -geometry 800x800 -quality 75 M:PhotoIMG_6800.JPG[0] M:Preview_-_M_-_PhotoIMG_6800.JPGp13.jpg
06/06/2014 08:38:08 PM|Preview:Preview cannot be generated, adding to list of bad files:M:PhotoIMG_6800.JPG


Not sure why the conversion is occurring but I get the "adding to list of bad files" notice.
Thoughts?

spinkb @ Sat Jun 07 03:40:28 EEST 2014
Is there a permissions issue?

Are you sure the image generated properly?

CrushFTP uses a test if the file expected doesn't exist, its assumed it failed...so that 3.jpg file should exist after the command runs.

What if you do the command manually from a DOS prompt, any more info there?
Serte @ Sat Jun 07 05:50:01 EEST 2014
Thanks for your assistance.
Using the command line manually generates the image properly. So the thumbnail is being made (at the proper resolution of 800xwhatever, with what appears to be the correct filename.

There shouldn't be a permissions issue -- all of this is being done on the Administrator account.

I can't delete the preview folder manually without redirecting the Previews Path somewhere else and then restarting the server. So it appears CrushFTP has all the permissions it needs for that folder.

spinkb @ Sat Jun 07 08:34:24 EEST 2014
Email us directly, or post here in the forum a screenshot of your entire previews configuration.
Serte @ Tue Jun 10 11:20:08 EEST 2014
[img]http://www.sertia.us/Previews.jpg[/img]
spinkb @ Tue Jun 10 11:27:00 EEST 2014
Your screenshot references E: for your preview storage.

Your original log is referencing M:. Has this changed now?
Serte @ Tue Jun 10 13:03:37 EEST 2014
It has. I changed it in the process of determining if permissions was the core issue.
spinkb @ Tue Jun 10 14:58:03 EEST 2014
Email us directly. I think we need to do a screen sharing session and try and figure out what is going on.

--Ben
Login to post a comment