Start a new topic

CrushFTP inacessible after installing iRedMail on Ubuntu Server. How to fix? - FIXED

djivesp @ Tue May 06 09:56:06 EEST 2014
Hi guys,

Question is this:
CrushFTP is inacessible after installing iRedMail on Ubuntu Server.

iRedMail is an email server program. which uses several components - Apache and MySQL are amongst them.

I used to have crush http on 8080, and FTP on port 21. Both inaccessible.

If i run htop, I can see that java -DDir/var/opt/CrushFTP6_PC is running.

if I scan the server for services, 8080 and 21 aren't listed.

Where should I start? I have no idea what it could have done to damage CrushFTP.
1 Comment

djivesp @ Tue May 06 10:44:53 EEST 2014
I think i fixed it.

Turns out that iRedMail disables ufw (Ubuntu firewall) and modifies the iptables manually to allow only the mail services through (it's supposed to be installed onto a fresh system but I didn't do this.)

I already had created rules for the various services and port numbers in ufw.

So enabling ufw enforced those old rules and problem is gone :).

[code]sudo ufw status verbose[/code]
[code]sudo ufw enable[/code]
Login to post a comment