Start a new topic

Can't set max memory


We added some more memory to our server, but we still see the old value set in the dashboard. I understand the memory can be changed from the dashboard in CrushFTP 8.  I try to enter the new max memory value in bytes into the box which pops up, but it has no effect.  I tried entering a lower value than the memory on the server, but with the same result.   

What am I doing wrong?  I can't find an alternate way to change the memory in the settings page.  IF there is a config file somewhere which I can alter, that would be handy. 

We are on Version 8.2.1_54 and running under Linux.  

On linux, change this in the script file.

Search for "-Xmx" and change the value there.  Its in MegaBytes.

Thanks!  it worked!

This isn't working anymore this morning. No further changes were made overnight, but now I'm showing only 0.6GB of available memory, I set the value to 2048MB.  Do you know what went wrong here? 


Check your script.  Is it still set to -Xmx2048 ?  On t he active line and not the commented out line?

If so, restart CrushFTP daemon.  ./ restart

Yes, it's set to 2048M on the active line.  I restarted several times but it's not having any effect.  It's very strange that it worked initially then changed.  

Check how Crush is started....

ps aux | grep java

What started it?  What arguments?

Here is the output:

root 14964 0.0 0.0 188268 644 ? S 08:08 0:00 sudo nohup java -jar CrushFTP.jar -d

root 14971 1.9 7.9 1664384 162816 ? Sl 08:08 0:20 java -jar CrushFTP.jar -d

ec2-user 15979 0.0 0.0 110468 2032 pts/1 S+ 08:26 0:00 grep --color=auto java

root 28043 0.0 0.0 188268 644 pts/0 S 07:35 0:00 sudo nohup java -jar CrushFTP.jar -d

root 28044 2.5 14.9 3042816 305388 pts/0 Sl 07:35 1:17 java -jar CrushFTP.jar -d

Kill all java instances. Then start one with the script file. 

Thanks, that has done it! 

Login to post a comment