Start a new topic
Answered

fail to connect to CrushFtp using ftp protocol

I'm trying to login to the server using ftp

and the results are in the attachments


Best Answer

You do not have PASV ports configured for your server...  You need something like 2000-2100 configured and forwarded by your router/firewall.


Right now PASV fails since no ports have been opened for it.


Then in the admin, preferences, FTP port, APSV ports set the same range there.


Thanks,

Ben


What was logged in the CrushFTP.log file from your attempt?


What exact version of CrushFTP is this?


What FTP client were you using?

 this is the log when I tried to login

USER|12/27/2016 13:14:11.483|[FTP:3650::<client Ip>] READ : *USER mustafa*
USER|12/27/2016 13:14:11.499|[FTP:3650:mustafa:<client Ip>] WROTE: *331 Username OK.  Need password.*
PASS|12/27/2016 13:14:11.499|[FTP:3650:mustafa:<client Ip>] READ : *PASS*
USER|12/27/2016 13:14:11.546|[FTP:3650:mustafa:<client Ip>] WROTE: *230 Password OK.  Connected. logged in*
SYST|12/27/2016 13:14:11.546|[FTP:3650:mustafa:<client Ip>] READ : *SYST *
SYST|12/27/2016 13:14:11.546|[FTP:3650:mustafa:<client Ip>] WROTE: *215 UNIX Type: L8*
PWD|12/27/2016 13:14:11.577|[FTP:3650:mustafa:<client Ip>] READ : *PWD *
PWD|12/27/2016 13:14:11.577|[FTP:3650:mustafa:<client Ip>] WROTE: *257 "/" PWD command successful.*
TYPE|12/27/2016 13:14:11.577|[FTP:3650:mustafa:<client Ip>] READ : *TYPE I*
TYPE|12/27/2016 13:14:11.577|[FTP:3650:mustafa:<client Ip>] WROTE: *200 Command ok : Binary type selected.*
SIZE|12/27/2016 13:14:11.577|[FTP:3650:mustafa:<client Ip>] READ : *SIZE /*
SIZE|12/27/2016 13:14:11.593|[FTP:3650:mustafa:<client Ip>] WROTE: *550 /: not a plain file.*
CWD|12/27/2016 13:14:11.593|[FTP:3650:mustafa:<client Ip>] READ : *CWD /*
CWD|12/27/2016 13:14:11.593|[FTP:3650:mustafa:<client Ip>] WROTE: *250 "/" CWD command successful.*
PASV|12/27/2016 13:14:11.593|[FTP:3650:mustafa:<client Ip>] READ : *PASV *
PASV|12/27/2016 13:14:11.593|[FTP:3650:mustafa:<client Ip>] WROTE: *227 Entering Passive Mode (62,212,73,226,218,212)*
PASV|12/27/2016 13:14:31.655|[FTP:3650:mustafa:<client Ip>] WROTE: *550-java.net.SocketTimeoutException: Accept timed out
PASV|12/27/2016 13:14:31.655|550 20 second timeout while waiting for PASV connection on port 56020.*
QUIT|12/27/2016 13:14:32.608|[FTP:3650:mustafa:<client Ip>] READ : *QUIT *
QUIT|12/27/2016 13:14:32.608|[FTP:3650:mustafa:<client Ip>] WROTE: *221 Goodbye.*
QUIT|12/27/2016 13:14:32.608|[FTP:3650:mustafa:<client Ip>] *Disconnected.*

 

CrushFTP Version 8.0.4_8


 

What FTP client were you using?


chrome browser and windows file explorer and filezella

Answer

You do not have PASV ports configured for your server...  You need something like 2000-2100 configured and forwarded by your router/firewall.


Right now PASV fails since no ports have been opened for it.


Then in the admin, preferences, FTP port, APSV ports set the same range there.


Thanks,

Ben

Login to post a comment