Start a new topic

crushftp mysql migration

showing error : Error:java.lang.ClassNotFoundException: com.mysql.jdbc.Driver


You don't have a MySQL JDBC driver file specified.  So configure that and get a JDBC jar driver file.

I have jar file in /plugins/lib : mysql-connector-java-5.1.40.jar 

Is it in correct location?

no...put it anywhere you like.  But set the jar location in the config where you did the test db button.  There are config entries for the jar, driver, url, etc.

Yes I also done with these entries


<stats_db_url>jdbc:mysql://127.0.0.1:3306/crushftp_stats</stats_db_url>
<stats_db_driver>com.mysql.jdbc.Driver</stats_db_driver>
<stats_db_user>root</stats_db_user>
<stats_db_driver_file>plugins/lib/mysql.jar</stats_db_driver_file>


still it showing error

Don't edit the file.


Use the UI, use browse, choose the file, use the path given after browsing.

Hii Ben,


Also tried it...but still not working..

Er02-NsgRkfAXU6J4Levic9zsLV70w6RUQ.png


The mysql driver you download also has info about what the class name is to be used for it.


That by default is typically "org.gjt.mm.mysql.Driver".  So you have changed it for some reason, did you change it correctly based on the jars you downloaded?


And why are you no longer pointing to "mysql-connector-java-5.1.40.jar"?


Every reply here you change one of the variables in what is failing and its hard to keep up with what you have changed and what the current issue is.


I did not change jar file

You did.  Earlier you said "mysql-connector-java-5.1.40.jar".  Now your saying "mysql.jar".  You changed the SQL driver too.  It was originally correct as "org.gjt.mm.mysql.Driver" and now your using "com.mysql.jdbc.Driver" which may also be correct, but based on your jar I don't know.


What exact MySQL driver file did you download?   What URL was used?

Previously I installed "mysql-connector-java-5.1.40.jar"  but renamed as  "mysql.jar" as per link I followed : http://www.crushftp.com/crush7wiki/Wiki.jsp?page=MySQL%20stats 

I downloaded that exact file, decompressed, and untarred it.  I got the file "mysql-connector-java-5.1.40-bin.jar" from the folder.


I then went to my stats config, browsed and chose that file.  I set the driver to be "com.mysql.jdbc.Driver" and the URL to be: "jdbc:mysql://127.0.0.1/crushftpstats?autoReconnect=true".


I clicked save, then test, and it worked.  So if you are getting class not found, you have a typo in your configuration or an old version of CrushFTP, etc.

Your getting into sql stuff now. Nothing to do with CrushFTP. Your root user is not allowed to connect from local host. It's sql permissions you have to fix.
Login to post a comment